FÓRUM DigiVoice

Fórum de Suporte Digivoice

Você não está logado.

#1 14/12/2007 16:04:42

ryukio
New member
Cadastrado: 03/12/2007
Posts: 4

kernel panic

Olá,
Estou instalando uma placa VB0408PCI-8 num servidor com asterisk e estou enfrentando kernel panic´s
Ao digitar dglist, ocorre um "segmentation fault". ao digitar novamente dglist ocorre o kernel panic.

Gostaria de saber se essa combinação funciona:
kernel 2.6.17
voicerlib 4.0.9.5
channel driver asrerisk 0.9.6




grato

Offline

 

#2 17/12/2007 16:50:55

ryukio
New member
Cadastrado: 03/12/2007
Posts: 4

Re: kernel panic

Descobri que o kernel panic só acontece quando o módulo VB0408-EXP (para expandir para 8 canais) está instalado e o Jumper JP1 é removido. Sem esse módulo funciona normalmente, porém só fico com 4 portas.
Testei várias versões de kernel do linux e o problema se repete. Não há conflito de IRQ.
Tentei substituir tanto a placa quanto o módulo por outros (compramos 2 placas com 2 módulos), e o problema se repete (só a placa funciona, mas quando coloco o módulo, kernel panic após alguns dglist)

Alguém sabe dizer por que isso ocorre?

Última alteração por ryukio (18/12/2007 07:03:40)

Offline

 

#3 18/12/2007 08:22:46

douglas
Member
Cadastrado: 01/02/2005
Posts: 201

Re: kernel panic

Ola ryukio

A placa VB0408 tem que funcionar da sequinte forma:

Quando usada com 08 canais (com placa de expansão) o jumper JP1 deve ficar aberto.
Quando for usar com 04 canais (sem placa de expansão) o jumper JP1 deve ficar fechado.

O não acredito que você esteja com duas placas com problemas, você pode fazer um teste com o programa de teste das placas da Digivoice "vlib_diag".

Pare seu asterisk e digite inicie o "vlib_diag"
Na tela você terá os comando que podem ser usados para testar todos os canais da sua placa.

Se no programa de teste der os problemas, encaminhe as placas para a Digivoice, do contrario, o problema deverá estar no sistema.


Douglas - Suporte

Offline

 

#4 18/12/2007 10:58:49

ryukio
New member
Cadastrado: 03/12/2007
Posts: 4

Re: kernel panic

Douglas,

Ocorre o mesmo problema executando o vlib_diag:
-----------------------------------------------------------
[root@localhost ~]# vlib_diag
OK....
Setting Sync for card 1 - EXTERNAL LINE_A....
Setting General Defaults....
Starting GUI....
* * * Goodbye! * * *

[root@localhost ~]# vlib_diag
Segmentation fault
-----------------------------------------------------------


E sem o módulo isso não acontece.




Quando isso acontece, se olhar no /proc/interrupts, parece que o vlibd ficou "preso":
-----------------------------------------------------------
                      CPU0       CPU1       
             0:     147891          0    IO-APIC-edge  timer
             8:          0          0    IO-APIC-edge  rtc
             9:          1          0   IO-APIC-level  acpi
            14:       1192          0    IO-APIC-edge  ide0
            50:          0          0   IO-APIC-level  uhci_hcd:usb4
            58:          0          0   IO-APIC-level  uhci_hcd:usb5
           169:         62          0   IO-APIC-level  eth0
----->  201:      13732          0   IO-APIC-level  /dev/vlibd
           217:       3249          0   IO-APIC-level  libata
           225:          2          0   IO-APIC-level  ehci_hcd:usb1, uhci_hcd:usb2
           233:        654          0   IO-APIC-level  uhci_hcd:usb3
           NMI:          0          0
           LOC:     147770     147821
           ERR:          0
           MIS:          0
-----------------------------------------------------------




Voce sabe o que pode estar causando isso? Será possível 2 placas com problema?




segue um dmesg:
-----------------------------------------------------------
Linux version 2.6.11-1.1369_FC4smp (bhcompile@decompose.build.redhat.com) (gcc version 4.0.0 20050525 (Red Hat 4.0.0-9)) #1 SMP Thu Jun 2 23:08:39 EDT 2005
BIOS-provided physical RAM map:
BIOS-e820: 0000000000000000 - 00000000000a0000 (usable)
BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
BIOS-e820: 0000000000100000 - 000000001fd86c00 (usable)
BIOS-e820: 000000001fd86c00 - 000000001fd88c00 (ACPI NVS)
BIOS-e820: 000000001fd88c00 - 000000001fd8ac00 (ACPI data)
BIOS-e820: 000000001fd8ac00 - 0000000020000000 (reserved)
BIOS-e820: 00000000e0000000 - 00000000f0000000 (reserved)
BIOS-e820: 00000000fec00000 - 00000000fed00400 (reserved)
BIOS-e820: 00000000fed20000 - 00000000feda0000 (reserved)
BIOS-e820: 00000000fee00000 - 00000000fef00000 (reserved)
BIOS-e820: 00000000ffb00000 - 0000000100000000 (reserved)
0MB HIGHMEM available.
509MB LOWMEM available.
found SMP MP-table at 000fe710
NX (Execute Disable) protection: active
On node 0 totalpages: 130438
  DMA zone: 4096 pages, LIFO batch:1
  Normal zone: 126342 pages, LIFO batch:31
  HighMem zone: 0 pages, LIFO batch:1
DMI 2.3 present.
Using APIC driver default
ACPI: RSDP (v000 DELL                                  ) @ 0x000fec00
ACPI: RSDT (v001 DELL    GX280   0x00000007 ASL  0x00000061) @ 0x000fcc05
ACPI: FADT (v001 DELL    GX280   0x00000007 ASL  0x00000061) @ 0x000fcc45
ACPI: SSDT (v001   DELL    st_ex 0x00001000 MSFT 0x0100000d) @ 0xfffd3808
ACPI: MADT (v001 DELL    GX280   0x00000007 ASL  0x00000061) @ 0x000fccb9
ACPI: BOOT (v001 DELL    GX280   0x00000007 ASL  0x00000061) @ 0x000fcd2b
ACPI: ASF! (v016 DELL    GX280   0x00000007 ASL  0x00000061) @ 0x000fcd53
ACPI: MCFG (v001 DELL    GX280   0x00000007 ASL  0x00000061) @ 0x000fcdba
ACPI: HPET (v001 DELL    GX280   0x00000007 ASL  0x00000061) @ 0x000fcdf8
ACPI: DSDT (v001   DELL    dt_ex 0x00001000 MSFT 0x0100000d) @ 0x00000000
ACPI: PM-Timer IO Port: 0x808
ACPI: Local APIC address 0xfee00000
ACPI: LAPIC (acpi_id[0x01] lapic_id[0x00] enabled)
Processor #0 15:4 APIC version 20
ACPI: LAPIC (acpi_id[0x02] lapic_id[0x01] enabled)
Processor #1 15:4 APIC version 20
ACPI: LAPIC (acpi_id[0x03] lapic_id[0x01] disabled)
ACPI: LAPIC (acpi_id[0x04] lapic_id[0x07] disabled)
ACPI: LAPIC_NMI (acpi_id[0xff] high level lint[0x1])
ACPI: IOAPIC (id[0x08] address[0xfec00000] gsi_base[0])
IOAPIC[0]: apic_id 8, version 32, address 0xfec00000, GSI 0-23
ACPI: INT_SRC_OVR (bus 0 bus_irq 0 global_irq 2 dfl dfl)
ACPI: INT_SRC_OVR (bus 0 bus_irq 9 global_irq 9 high level)
ACPI: IRQ0 used by override.
ACPI: IRQ2 used by override.
ACPI: IRQ9 used by override.
Enabling APIC mode:  Flat.  Using 1 I/O APICs
ACPI: HPET id: 0x8086a201 base: 0xfed00000
Using ACPI (MADT) for SMP configuration information
Allocating PCI resources starting at 20000000 (gap: 20000000:c0000000)
Built 1 zonelists
Kernel command line: ro root=/dev/VolGroup00/LogVol00 rhgb quiet
mapped APIC to ffffd000 (fee00000)
mapped IOAPIC to ffffc000 (fec00000)
Initializing CPU#0
CPU 0 irqstacks, hard=c042a000 soft=c040a000
PID hash table entries: 2048 (order: 11, 32768 bytes)
Console: colour VGA+ 80x25
Dentry cache hash table entries: 65536 (order: 6, 262144 bytes)
Inode-cache hash table entries: 32768 (order: 5, 131072 bytes)
Memory: 510148k/521752k available (2084k kernel code, 11040k reserved, 769k data, 232k init, 0k highmem)
Checking if this processor honours the WP bit even in supervisor mode... Ok.
hpet0: at MMIO 0xfed00000, IRQs 2, 8, 0
hpet0: 0ns tick, 3 64-bit timers
Using HPET for base-timer
Using HPET for gettimeofday
Detected 2793.312 MHz processor.
Using hpet for high-res timesource
Calibrating delay loop... 5537.79 BogoMIPS (lpj=2768896)
Security Framework v1.0.0 initialized
SELinux:  Initializing.
SELinux:  Starting in permissive mode
selinux_register_security:  Registering secondary module capability
Capability LSM initialized as secondary
Mount-cache hash table entries: 512
CPU: After generic identify, caps: bfebfbff 00100000 00000000 00000000 0000441d 00000000 00000000
CPU: After vendor identify, caps: bfebfbff 00100000 00000000 00000000 0000441d 00000000 00000000
monitor/mwait feature present.
using mwait in idle threads.
CPU: Trace cache: 12K uops, L1 D cache: 16K
CPU: L2 cache: 1024K
CPU: Physical Processor ID: 0
CPU: After all inits, caps: bfebfbff 00100000 00000000 00000080 0000441d 00000000 00000000
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#0.
CPU0: Intel P4/Xeon Extended MCE MSRs (12) available
CPU0: Thermal monitoring enabled
Enabling fast FPU save and restore... done.
Enabling unmasked SIMD FPU exception support... done.
Checking 'hlt' instruction... OK.
CPU0: Intel(R) Pentium(R) 4 CPU 2.80GHz stepping 01
Booting processor 1/1 eip 3000
CPU 1 irqstacks, hard=c042b000 soft=c040b000
Initializing CPU#1
Calibrating delay loop... 5586.94 BogoMIPS (lpj=2793472)
CPU: After generic identify, caps: bfebfbff 00100000 00000000 00000000 0000441d 00000000 00000000
CPU: After vendor identify, caps: bfebfbff 00100000 00000000 00000000 0000441d 00000000 00000000
monitor/mwait feature present.
CPU: Trace cache: 12K uops, L1 D cache: 16K
CPU: L2 cache: 1024K
CPU: Physical Processor ID: 0
CPU: After all inits, caps: bfebfbff 00100000 00000000 00000080 0000441d 00000000 00000000
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#1.
CPU1: Intel P4/Xeon Extended MCE MSRs (12) available
CPU1: Thermal monitoring enabled
CPU1: Intel(R) Pentium(R) 4 CPU 2.80GHz stepping 01
Total of 2 processors activated (11124.73 BogoMIPS).
ENABLING IO-APIC IRQs
..TIMER: vector=0x31 pin1=2 pin2=-1
checking TSC synchronization across 2 CPUs: passed.
softlockup thread 0 started up.
Brought up 2 CPUs
softlockup thread 1 started up.
checking if image is initramfs... it is
Freeing initrd memory: 1753k freed
NET: Registered protocol family 16
PCI: PCI BIOS revision 2.10 entry at 0xfb258, last bus=4
PCI: Using MMCONFIG
mtrr: v2.0 (20020519)
ACPI: Subsystem revision 20050309
ACPI: Interpreter enabled
ACPI: Using IOAPIC for interrupt routing
ACPI: PCI Root Bridge [PCI0] (0000:00)
PCI: Probing PCI hardware (bus 00)
Boot video device is 0000:00:02.0
PCI: Ignoring BAR0-3 of IDE controller 0000:00:1f.1
PCI: Transparent bridge - 0000:00:1e.0
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT]
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.PCI1._PRT]
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.PCI2._PRT]
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.PCI3._PRT]
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.PCI4._PRT]
ACPI: PCI Interrupt Link [LNKA] (IRQs 3 4 5 6 7 9 10 *11 12 15)
ACPI: PCI Interrupt Link [LNKB] (IRQs 3 4 5 6 7 9 *10 11 12 15)
ACPI: PCI Interrupt Link [LNKC] (IRQs 3 *4 5 6 7 9 10 11 12 15)
ACPI: PCI Interrupt Link [LNKD] (IRQs 3 4 5 6 7 9 10 11 12 15) *0, disabled.
ACPI: PCI Interrupt Link [LNKE] (IRQs 3 4 5 6 7 9 *10 11 12 15)
ACPI: PCI Interrupt Link [LNKF] (IRQs 3 4 5 6 7 *9 10 11 12 15)
ACPI: PCI Interrupt Link [LNKG] (IRQs 3 4 *5 6 7 9 10 11 12 15)
ACPI: PCI Interrupt Link [LNKH] (IRQs *3 4 5 6 7 9 10 11 12 15)
Linux Plug and Play Support v0.97 (c) Adam Belay
pnp: PnP ACPI init
pnp: PnP ACPI: found 9 devices
usbcore: registered new driver usbfs
usbcore: registered new driver hub
PCI: Using ACPI for IRQ routing
PCI: If a device doesn't work, try "pci=routeirq".  If it helps, post a report
pnp: 00:00: ioport range 0x800-0x85f could not be reserved
pnp: 00:00: ioport range 0xc00-0xc7f has been reserved
pnp: 00:00: ioport range 0x860-0x8ff has been reserved
pnp: 00:07: ioport range 0x100-0x1fe has been reserved
pnp: 00:07: ioport range 0x200-0x277 has been reserved
pnp: 00:07: ioport range 0x280-0x2e7 has been reserved
pnp: 00:07: ioport range 0x2f0-0x2f7 has been reserved
pnp: 00:07: ioport range 0x300-0x377 has been reserved
pnp: 00:07: ioport range 0x380-0x3bb has been reserved
pnp: 00:07: ioport range 0x3c0-0x3e7 could not be reserved
pnp: 00:07: ioport range 0x3f6-0x3f7 has been reserved
Simple Boot Flag value 0x87 read from CMOS RAM was invalid
Simple Boot Flag at 0x7a set to 0x1
apm: BIOS version 1.2 Flags 0x03 (Driver version 1.16ac)
apm: disabled - APM is not SMP safe.
audit: initializing netlink socket (disabled)
audit(1197974736.863:1): initialized
Total HugeTLB memory allocated, 0
VFS: Disk quotas dquot_6.5.1
Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
SELinux:  Registering netfilter hooks
Initializing Cryptographic API
ksign: Installing public key data
Loading keyring
- Added public key 42BD35A990375F72
- User ID: Red Hat, Inc. (Kernel Module GPG key)
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
ACPI: PCI Interrupt 0000:00:01.0[A] -> GSI 16 (level, low) -> IRQ 169
PCI: Setting latency timer of device 0000:00:01.0 to 64
assign_interrupt_mode Found MSI capability
Allocate Port Service[pcie00]
Allocate Port Service[pcie03]
ACPI: PCI Interrupt 0000:00:1c.0[A] -> GSI 16 (level, low) -> IRQ 169
PCI: Setting latency timer of device 0000:00:1c.0 to 64
assign_interrupt_mode Found MSI capability
Allocate Port Service[pcie00]
Allocate Port Service[pcie02]
Allocate Port Service[pcie03]
ACPI: PCI Interrupt 0000:00:1c.1[b] -> GSI 17 (level, low) -> IRQ 201
PCI: Setting latency timer of device 0000:00:1c.1 to 64
assign_interrupt_mode Found MSI capability
Allocate Port Service[pcie00]
Allocate Port Service[pcie03]
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found
Real Time Clock Driver v1.12
hpet_acpi_add: no address or irqs in _CRS
Linux agpgart interface v0.101 (c) Dave Jones
agpgart: Detected an Intel 915G Chipset.
agpgart: Detected 764K stolen memory.
agpgart: AGP aperture is 256M @ 0xc0000000
PNP: No PS/2 controller found. Probing ports directly.
serio: i8042 AUX port at 0x60,0x64 irq 12
serio: i8042 KBD port at 0x60,0x64 irq 1
Serial: 8250/16550 driver $Revision: 1.90 $ 76 ports, IRQ sharing enabled
io scheduler noop registered
io scheduler anticipatory registered
io scheduler deadline registered
io scheduler cfq registered
RAMDISK driver initialized: 16 RAM disks of 16384K size 1024 blocksize
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
ICH6: IDE controller at PCI slot 0000:00:1f.1
ACPI: PCI Interrupt 0000:00:1f.1[A] -> GSI 16 (level, low) -> IRQ 169
ICH6: chipset revision 3
ICH6: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0xffa0-0xffa7, BIOS settings: hda:DMA, hdb:pio
Probing IDE interface ide0...
hda: SAMSUNG CD-ROM SC-148A, ATAPI CD/DVD-ROM drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
Probing IDE interface ide1...
hda: ATAPI 48X CD-ROM drive, 128kB Cache, UDMA(33)
Uniform CD-ROM driver Revision: 3.20
ide-floppy driver 0.99.newide
usbcore: registered new driver hiddev
usbcore: registered new driver usbhid
drivers/usb/input/hid-core.c: v2.01:USB HID core driver
mice: PS/2 mouse device common for all mice
md: md driver 0.90.1 MAX_MD_DEVS=256, MD_SB_DISKS=27
NET: Registered protocol family 2
IP: routing cache hash table of 2048 buckets, 32Kbytes
TCP established hash table entries: 16384 (order: 6, 262144 bytes)
TCP bind hash table entries: 16384 (order: 5, 196608 bytes)
TCP: Hash tables configured (established 16384 bind 16384)
Initializing IPsec netlink socket
NET: Registered protocol family 1
NET: Registered protocol family 17
ACPI wakeup devices:
VBTN PCI0 PCI1 PCI2 PCI3 PCI4 USB0 USB1 USB2 USB3
ACPI: (supports S0 S1 S3 S4 S5)
CPU0 attaching sched-domain:
domain 0: span 00000003
  groups: 00000001 00000002
  domain 1: span 00000003
   groups: 00000003
CPU1 attaching sched-domain:
domain 0: span 00000003
  groups: 00000002 00000001
  domain 1: span 00000003
   groups: 00000003
Freeing unused kernel memory: 232k freed
SCSI subsystem initialized
libata version 1.10 loaded.
ata_piix version 1.03
ACPI: PCI Interrupt 0000:00:1f.2[C] -> GSI 20 (level, low) -> IRQ 217
PCI: Setting latency timer of device 0000:00:1f.2 to 64
ata1: SATA max UDMA/133 cmd 0xFE00 ctl 0xFE12 bmdma 0xFEA0 irq 217
ata2: SATA max UDMA/133 cmd 0xFE20 ctl 0xFE32 bmdma 0xFEA8 irq 217
ata1: dev 0 cfg 49:2f00 82:346b 83:5b01 84:4003 85:3469 86:1801 87:4003 88:203f
ata1: dev 0 ATA, max UDMA/100, 78125000 sectors:
ata1: dev 0 configured for UDMA/100
scsi0 : ata_piix
ATA: abnormal status 0xFF on port 0xFE27
ata2: disabling port
scsi1 : ata_piix
  Vendor: ATA       Model: WDC WD400BD-75JM  Rev: 06.0
  Type:   Direct-Access                      ANSI SCSI revision: 05
SCSI device sda: 78125000 512-byte hdwr sectors (40000 MB)
SCSI device sda: drive cache: write back
SCSI device sda: 78125000 512-byte hdwr sectors (40000 MB)
SCSI device sda: drive cache: write back
sda: sda1 sda2
Attached scsi disk sda at scsi0, channel 0, id 0, lun 0
device-mapper: 4.4.0-ioctl (2005-01-12) initialised: dm-devel@redhat.com
kjournald starting.  Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
SELinux:  Disabled at runtime.
SELinux:  Unregistering netfilter hooks
Floppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077
tg3.c:v3.29 (May 23, 2005)
ACPI: PCI Interrupt 0000:02:00.0[A] -> GSI 16 (level, low) -> IRQ 169
PCI: Setting latency timer of device 0000:02:00.0 to 64
eth0: Tigon3 [partno(BCM95751) rev 4001 PHY(5750)] (PCIX:100MHz:32-bit) 10/100/1000BaseT Ethernet 00:12:3f:fe:c2:25
eth0: RXcsums[1] LinkChgREG[1] MIirq[1] ASF[0] Split[0] WireSpeed[1] TSOcap[1]
eth0: dma_rwctrl[76180000]
hw_random hardware driver 1.0.0 loaded
shpchp: acpi_shpchprm:\_SB_.PCI0 evaluate _BBN fail=0x5
shpchp: acpi_shpchprm:get_device PCI ROOT HID fail=0x5
shpchp: acpi_shpchprm:\_SB_.PCI0 evaluate _BBN fail=0x5
shpchp: acpi_shpchprm:get_device PCI ROOT HID fail=0x5
shpchp: acpi_shpchprm:\_SB_.PCI0 evaluate _BBN fail=0x5
shpchp: acpi_shpchprm:get_device PCI ROOT HID fail=0x5
Zapata Telephony Interface Registered on major 196
Zaptel Version: 1.2.22
Zaptel Echo Canceller: KB1
ACPI: PCI Interrupt 0000:04:01.0[A] -> GSI 17 (level, low) -> IRQ 201
Invalid Xilinx 8 bit Base resource
Registered Tormenta2 PCI
ACPI: PCI Interrupt 0000:00:1d.7[A] -> GSI 21 (level, low) -> IRQ 225
PCI: Setting latency timer of device 0000:00:1d.7 to 64
ehci_hcd 0000:00:1d.7: EHCI Host Controller
ehci_hcd 0000:00:1d.7: debug port 1
ehci_hcd 0000:00:1d.7: new USB bus registered, assigned bus number 1
ehci_hcd 0000:00:1d.7: irq 225, io mem 0xffa80800
PCI: cache line size of 128 is not supported by device 0000:00:1d.7
ehci_hcd 0000:00:1d.7: USB 2.0 initialized, EHCI 1.00, driver 10 Dec 2004
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 8 ports detected
USB Universal Host Controller Interface driver v2.2
ACPI: PCI Interrupt 0000:00:1d.0[A] -> GSI 21 (level, low) -> IRQ 225
PCI: Setting latency timer of device 0000:00:1d.0 to 64
uhci_hcd 0000:00:1d.0: UHCI Host Controller
uhci_hcd 0000:00:1d.0: new USB bus registered, assigned bus number 2
uhci_hcd 0000:00:1d.0: irq 225, io base 0x0000ff80
hub 2-0:1.0: USB hub found
hub 2-0:1.0: 2 ports detected
ACPI: PCI Interrupt 0000:00:1d.1[b] -> GSI 22 (level, low) -> IRQ 233
PCI: Setting latency timer of device 0000:00:1d.1 to 64
uhci_hcd 0000:00:1d.1: UHCI Host Controller
uhci_hcd 0000:00:1d.1: new USB bus registered, assigned bus number 3
uhci_hcd 0000:00:1d.1: irq 233, io base 0x0000ff60
hub 3-0:1.0: USB hub found
hub 3-0:1.0: 2 ports detected
ACPI: PCI Interrupt 0000:00:1d.2[C] -> GSI 18 (level, low) -> IRQ 50
PCI: Setting latency timer of device 0000:00:1d.2 to 64
uhci_hcd 0000:00:1d.2: UHCI Host Controller
uhci_hcd 0000:00:1d.2: new USB bus registered, assigned bus number 4
uhci_hcd 0000:00:1d.2: irq 50, io base 0x0000ff40
hub 4-0:1.0: USB hub found
hub 4-0:1.0: 2 ports detected
ACPI: PCI Interrupt 0000:00:1d.3[D] -> GSI 23 (level, low) -> IRQ 58
PCI: Setting latency timer of device 0000:00:1d.3 to 64
uhci_hcd 0000:00:1d.3: UHCI Host Controller
uhci_hcd 0000:00:1d.3: new USB bus registered, assigned bus number 5
uhci_hcd 0000:00:1d.3: irq 58, io base 0x0000ff20
hub 5-0:1.0: USB hub found
hub 5-0:1.0: 2 ports detected
usb 3-1: new low speed USB device using uhci_hcd and address 2
input: USB HID v1.10 Keyboard [Dell Dell USB Keyboard] on usb-0000:00:1d.1-1
ACPI: Power Button (FF) [PWRF]
ibm_acpi: ec object not found
md: Autodetecting RAID arrays.
md: autorun ...
md: ... autorun DONE.
EXT3 FS on dm-0, internal journal
kjournald starting.  Commit interval 5 seconds
EXT3 FS on sda1, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
Adding 1048568k swap on /dev/VolGroup00/LogVol01.  Priority:-1 extents:1
tg3: eth0: Link is up at 10 Mbps, half duplex.
tg3: eth0: Flow control is off for TX and off for RX.
>vlibd: vlib_init_module - Starting loading driver...
vlibd: Module /dev/vlibd using major number 254
vlibd: Driver Version: 4.0.9.6
vlibd: VoicerLib Device Driver was loaded successfully!
NET: Registered protocol family 10
Disabled Privacy Extensions on device c037d640(lo)
IPv6 over IPv4 tunneling driver
eth0: no IPv6 routers present
vlibd->init_plx: Probing Device Name: vlibd
vlibd->plx_countcards: 1 Cards Found.
vlibd->plx_probe: ->Probing card number 0
ACPI: PCI Interrupt 0000:04:01.0[A] -> GSI 17 (level, low) -> IRQ 201
kobject_register failed for vlibd (-17)
[<c01d2acb>] kobject_register+0x51/0x59
[<c023cca4>] bus_add_driver+0x56/0xb6
[<c01ddf87>] pci_register_driver+0x73/0x88
[<e0a4d453>] init_plx+0x61/0xf8 [vlibd]
[<e0a50d7c>] vlib_ioctl+0x55a/0x8b7 [vlibd]
[<c0142c36>] audit_syscall_entry+0x132/0x160
[<c0172c14>] do_ioctl+0x64/0x6d
[<c0172d77>] vfs_ioctl+0x56/0x1d0
[<c0172f4e>] sys_ioctl+0x5d/0x6b
[<c0104025>] syscall_call+0x7/0xb
vlibd->init_plx: Probing Device Name: vlibd
vlibd->plx_countcards: 1 Cards Found.
kobject_register failed for vlibd (-17)
[<c01d2acb>] kobject_register+0x51/0x59
[<c023cca4>] bus_add_driver+0x56/0xb6
[<c01ddf87>] pci_register_driver+0x73/0x88
[<e0a4d453>] init_plx+0x61/0xf8 [vlibd]
[<e0a50d7c>] vlib_ioctl+0x55a/0x8b7 [vlibd]
[<c0142c36>] audit_syscall_entry+0x132/0x160
[<c0172c14>] do_ioctl+0x64/0x6d
[<c0172d77>] vfs_ioctl+0x56/0x1d0
[<c0172f4e>] sys_ioctl+0x5d/0x6b
[<c0104025>] syscall_call+0x7/0xb
vlibd->init_plx: Probing Device Name: vlibd
vlibd->plx_countcards: 1 Cards Found.
kobject_register failed for vlibd (-17)
[<c01d2acb>] kobject_register+0x51/0x59
[<c023cca4>] bus_add_driver+0x56/0xb6
[<c01ddf87>] pci_register_driver+0x73/0x88
[<e0a4d453>] init_plx+0x61/0xf8 [vlibd]
[<e0a50d7c>] vlib_ioctl+0x55a/0x8b7 [vlibd]
[<c0142c36>] audit_syscall_entry+0x132/0x160
[<c0172c14>] do_ioctl+0x64/0x6d
[<c0172d77>] vfs_ioctl+0x56/0x1d0
[<c0172f4e>] sys_ioctl+0x5d/0x6b
[<c0104025>] syscall_call+0x7/0xb
vlibd->init_plx: Probing Device Name: vlibd
vlibd->plx_countcards: 1 Cards Found.
kobject_register failed for vlibd (-17)
[<c01d2acb>] kobject_register+0x51/0x59
[<c023cca4>] bus_add_driver+0x56/0xb6
[<c01ddf87>] pci_register_driver+0x73/0x88
[<e0a4d453>] init_plx+0x61/0xf8 [vlibd]
[<e0a50d7c>] vlib_ioctl+0x55a/0x8b7 [vlibd]
[<c0142c36>] audit_syscall_entry+0x132/0x160
[<c0172c14>] do_ioctl+0x64/0x6d
[<c0172d77>] vfs_ioctl+0x56/0x1d0
[<c0172f4e>] sys_ioctl+0x5d/0x6b
[<c0104025>] syscall_call+0x7/0xb
vlibd->init_plx: Probing Device Name: vlibd
vlibd->plx_countcards: 1 Cards Found.
kobject_register failed for vlibd (-17)
[<c01d2acb>] kobject_register+0x51/0x59
[<c023cca4>] bus_add_driver+0x56/0xb6
[<c01ddf87>] pci_register_driver+0x73/0x88
[<e0a4d453>] init_plx+0x61/0xf8 [vlibd]
[<e0a50d7c>] vlib_ioctl+0x55a/0x8b7 [vlibd]
[<c0142c36>] audit_syscall_entry+0x132/0x160
[<c0172c14>] do_ioctl+0x64/0x6d
[<c0172d77>] vfs_ioctl+0x56/0x1d0
[<c0172f4e>] sys_ioctl+0x5d/0x6b
[<c0104025>] syscall_call+0x7/0xb
>vlibd: vlib_cleanup_module: unloading voicerlib module.
vlibd: Unregistering /dev/vlibd with major = 254
vlibd: VoicerLib Device Driver Unloaded!
Unable to handle kernel paging request at virtual address e0a5179a
printing eip:
c01d5c6f
*pde = 00000000
Oops: 0000 [#1]
SMP
Modules linked in: md5 ipv6 autofs4 sunrpc video button battery ac uhci_hcd ehci_hcd tor2(U) zaptel(U) crc_ccitt hw_random i2c_i801 i2c_core tg3 floppy dm_snapshot dm_zero dm_mirror ext3 jbd dm_mod ata_piix libata sd_mod scsi_mod
CPU:    0
EIP:    0060:[<c01d5c6f>]    Not tainted VLI
EFLAGS: 00010097   (2.6.11-1.1369_FC4smp)
EIP is at vsnprintf+0x431/0x5f6
eax: e0a5179a   ebx: c0327b00   ecx: e0a5179a   edx: fffffffe
esi: dc1fd1b7   edi: dc1fdfff   ebp: ffffffff   esp: df4b5ec0
ds: 007b   es: 007b   ss: 0068
Process cat (pid: 2965, threadinfo=df4b5000 task=decab020)
Stack: 00000000 00000000 0000000a 0000000a 00000001 00000000 00000e4b dc1fd1b5
       0000000a 00000000 ffffffff ffffffff c0327b61 df4b5f30 c0327b61 dc1fd1b5
       ddf36e80 ddf36e80 c0402be0 c017fcb2 df4b5f2c df4b5f2c 00000020 00006480
Call Trace:
[<c017fcb2>] seq_printf+0x2d/0x50
[<c010689d>] show_interrupts+0x146/0x279
[<c017f86b>] seq_read+0x25e/0x2b6
[<c017f60d>] seq_read+0x0/0x2b6
[<c0161ddb>] vfs_read+0x9c/0x10e
[<c016208a>] sys_read+0x41/0x6a
[<c0104025>] syscall_call+0x7/0xb
Code: 50 fc ff ff 8b 44 24 50 83 c0 04 89 44 24 34 8b 54 24 50 8b 0a 81 f9 ff 0f 00 00 b8 29 77 32 c0 0f 46 c8 8b 54 24 2c 89 c8 eb 06 <80> 38 00 74 07 40 4a 83 fa ff 75 f4 29 c8 89 c3 8b 6c 24 28 f6

Última alteração por ryukio (18/12/2007 11:03:07)

Offline

 

#5 27/12/2007 23:26:10

jobel
New member
Cadastrado: 16/02/2005
Posts: 6

Re: kernel panic

Tenho tido os mesmos problemas citados acima e tive que abortar o projeto asterisk com VB0408PCI-8.
Outra informação que tenho é que acontece o problema com 4 portas mas com uma frequencia muito menor do que com 8 portas.
Expliquei o problema ao suporte e a unica informação que tive de retorno é que não dão suporte ao asterisk.

Entendo perfeitamente, porem já fiz várias instalaçoes de asterisk e só tenho problemas com o hardware digivoice ?
Tenho 4 placas vb0408/8 e gostaria sinceramente que olhassem o problema com mais cuidado e não nos deixassem achando que o problema é no nosso hardware (MICRO)  ou configuração mal feita.

Já testei com 3 equipamentos dual core placa Asus e Intel e tive o mesmo problema em todas as vezes.

As vezes o asterisk funciona, mas se precisar reiniciar o driver recebo seg fault e aí só reiniciando a máquina.

kernel 2.6.18
voicerlib 4.0.9.5
channel driver asrerisk 0.9.6

Offline

 

#6 28/12/2007 14:11:44

ryukio
New member
Cadastrado: 03/12/2007
Posts: 4

Re: kernel panic

Pois é, é a nossa primeira experiência com placas Digivoice (sempre utilizamos Digium com o asterisk), e até agora não deu muito certo.
Porém no nosso caso o suporte foi mais atencioso e pediu para enviar as placas para análise.

Offline

 

#7 25/01/2015 16:03:08

greysonsilva
New member
Cadastrado: 31/12/1969
Posts: 1
Website

Re: kernel panic

Olá pessoal,
Estou usando uma Digivoice 9030 E1 e estou tendo problemas de kernel panic devido a este problema de IRQ conflituoso. Já usei o smp_affinity e agora estou acompanhando pra ver se persiste o problema. A máquina possui 12 portas USB e desativei as 10 traseiras porém precisei deixar as 2 frontais pq não tem porta PS/2 nesse servidor. Como eu não deixo plugado teclado nessas portas, será que o problema se resolve? Segue abaixo a saída do cat /proc/interrupts

  CPU0       CPU1       CPU2       CPU3       
  0:  162419297          0          0          0    IO-APIC-edge  timer
  1:          3          0          0          0    IO-APIC-edge  i8042
  8:          1          0          0          0    IO-APIC-edge  rtc
  9:          0          0          0          0   IO-APIC-level  acpi
12:          4          0          0          0    IO-APIC-edge  i8042
50:    2567711          0          0          0         PCI-MSI  ahci
82:      15141          0          0  114618155         PCI-MSI  eth1
169:          1      99999          0          0   IO-APIC-level  uhci_hcd:usb3
177:          2          0          0          0   IO-APIC-level  uhci_hcd:usb4, uhci_hcd:usb7
217:          0          0          0          0   IO-APIC-level  ehci_hcd:usb1, uhci_hcd:usb5
225:          0          0          0          0   IO-APIC-level  ehci_hcd:usb2, uhci_hcd:usb6
233:          1          0   81004759          0   IO-APIC-level  uhci_hcd:usb8, /dev/vlibd
NMI:       2444       7844      12062      18564
LOC:  162411306  162411235  163517253  163517193
ERR:          0
MIS:          0

Offline

 

#8 06/03/2015 23:17:21

jobel
New member
Cadastrado: 16/02/2005
Posts: 6

Re: kernel panic

olá Ryukio,

Alguma novidade em relação ao kernel panic? Tenho tido o mesmo problema e até agora ninguem da digivoice prestou-se a responder.

Offline

 

Rodapé do fórum

Powered by PunBB
© Copyright 2002–2005 Rickard Andersson